It is currently 18 Apr 2021, 05:55

Stopping 'faces' appearing

Where to ask all your SketchUp related questions or share your skills (in the case of our resident Guru Dave R…).

Stopping 'faces' appearing

Postby RogerS » 30 Mar 2021, 18:04

If that's the right term.

When you enclose a space with, say, a circle then the inside will go blue or white. But you can select and delete it leaving just the outline of the circle. Which is what I need for the staircase tangent drawings that I'm doing at the moment.

But is there a way to prevent that happening at all ?

TIA
Fewer Smart things. More smart people.
User avatar
RogerS
Sequoia
 
Posts: 8812
Joined: 21 Jul 2014, 21:07
Location: Nearly finished. OK OK...call me Pinocchio.
Name:

Re: Stopping 'faces' appearing

Postby Malc2098 » 30 Mar 2021, 20:23

If you delete the 'space', Roger, leaving just the circle, you can 'make group' the circle, so it is an entity in its own right.... I think.
Malcolm
User avatar
Malc2098
Sequoia
 
Posts: 5133
Joined: 03 Jul 2016, 11:10
Location: Tiverton
Name: Malcolm

Re: Stopping 'faces' appearing

Postby SamQ aka Ah! Q! » 30 Mar 2021, 20:57

I thought Roger was going paranoid at first...then realised it's a coded convo about CAD...I think...what if it isn't? :shock: What have I started? :shock: When will it end? :shock: Where can I go to get away from it? :shock:

:D Sam
SamQ aka Ah! Q!
Sapling
 
Posts: 482
Joined: 21 Jul 2014, 23:06
Name:

Re: Stopping 'faces' appearing

Postby RogerS » 30 Mar 2021, 22:33

Malc2098 wrote:If you delete the 'space', Roger, leaving just the circle, you can 'make group' the circle, so it is an entity in its own right.... I think.


Groups are verboten ! Components Rule KO ?
Fewer Smart things. More smart people.
User avatar
RogerS
Sequoia
 
Posts: 8812
Joined: 21 Jul 2014, 21:07
Location: Nearly finished. OK OK...call me Pinocchio.
Name:

Re: Stopping 'faces' appearing

Postby Dave R » 30 Mar 2021, 22:38

Roger, SketchUp is a surface modeler so there isn't anyway to prevent faces from being created. You can however prevent them from showing by changing the face style to Wireframe. Either edit the style or go to View>Face Style and choose it.
Dave R
Nordic Pine
 
Posts: 525
Joined: 22 Jul 2014, 13:38
Name:

Re: Stopping 'faces' appearing

Postby Dave R » 30 Mar 2021, 22:43

You might also consider using X-ray which would let you see through the faces.
Dave R
Nordic Pine
 
Posts: 525
Joined: 22 Jul 2014, 13:38
Name:

Re: Stopping 'faces' appearing

Postby RogerS » 30 Mar 2021, 22:43

Thanks, Dave. I thought of x-ray and dismissed it....but I was thinking 3d. My drawings are in 2d so no problem.

I tell you something for nothing....this tangent drawing is fair doing my head in.

But SU is bloody useful .. :D
Fewer Smart things. More smart people.
User avatar
RogerS
Sequoia
 
Posts: 8812
Joined: 21 Jul 2014, 21:07
Location: Nearly finished. OK OK...call me Pinocchio.
Name:

Re: Stopping 'faces' appearing

Postby Dave R » 30 Mar 2021, 22:47

Did you try Wireframe?

There's a lot of weird stuff going on. You might consider changing the Edge color to By Material and then apply materials to the edges as you go. And make sure you continue maintaining separate between sets of edges so they don't interact and intersect.
Dave R
Nordic Pine
 
Posts: 525
Joined: 22 Jul 2014, 13:38
Name:

Re: Stopping 'faces' appearing

Postby RogerS » 31 Mar 2021, 11:59

Wireframe works a treat although I don't seem to e able to make a component when in that mode.

I couldn't find Edge color to By Material in my version of SU (2017).

TIA, Dave
Fewer Smart things. More smart people.
User avatar
RogerS
Sequoia
 
Posts: 8812
Joined: 21 Jul 2014, 21:07
Location: Nearly finished. OK OK...call me Pinocchio.
Name:

Re: Stopping 'faces' appearing

Postby Robert » 31 Mar 2021, 12:25

I just made a component in wireframe view OK.

I treble clicked the outline of a circle then right clicked and made component. The invisible face of the circle appeared as a dotted surface when selected. Treble clicking selects all connected items so maybe you aren't selecting enough for the component if you are just clicking on single items?
Robert
Old Oak
 
Posts: 2006
Joined: 21 Jul 2014, 19:31
Location: Woodford Green
Name: Robert

Re: Stopping 'faces' appearing

Postby Dave R » 31 Mar 2021, 12:43

As Robert indicated you should be able to make a component in Wireframe. With the faces not displayed you have to do your treble click on an edge since there are no visible faces to click on. Alternatively you could drag a selection box around the geometry to select it.

As for the By Material thing, go to the Styles panel and choose the In Model styles by clicking on the small house icon. Select the style and click on the Edit tab. There's a row of cubes running across the panel under the Select, Edit, and Mic tabs. Click on the leftmost cube which is displayed in wireframe. Change the color at the bottom of the Edge settings.

Screenshot - 3_31_2021 , 6_38_21 AM.png
(15.32 KiB)


Screenshot - 3_31_2021 , 6_39_56 AM.png
(27.69 KiB)
Dave R
Nordic Pine
 
Posts: 525
Joined: 22 Jul 2014, 13:38
Name:

Re: Stopping 'faces' appearing

Postby RogerS » 31 Mar 2021, 13:22

Thanks Dave. All went well until this sentence..

Change the color at the bottom of the Edge settings.
Fewer Smart things. More smart people.
User avatar
RogerS
Sequoia
 
Posts: 8812
Joined: 21 Jul 2014, 21:07
Location: Nearly finished. OK OK...call me Pinocchio.
Name:

Re: Stopping 'faces' appearing

Postby Robert » 31 Mar 2021, 13:41

Think that just means selecting 'by material'.

Just tried it and drew a circle and dragged a colour material onto it so it went orange. in wireframe view I now have an orange circle instead of black.

Something else i've learned :)
Robert
Old Oak
 
Posts: 2006
Joined: 21 Jul 2014, 19:31
Location: Woodford Green
Name: Robert

Re: Stopping 'faces' appearing

Postby RogerS » 31 Mar 2021, 13:49

Robert wrote:Think that just means selecting 'by material'.

Just tried it and drew a circle and dragged a colour material onto it so it went orange. in wireframe view I now have an orange circle instead of black.

Something else i've learned :)


Did you have to use the Paint Bucket icon ?
Fewer Smart things. More smart people.
User avatar
RogerS
Sequoia
 
Posts: 8812
Joined: 21 Jul 2014, 21:07
Location: Nearly finished. OK OK...call me Pinocchio.
Name:

Re: Stopping 'faces' appearing

Postby Robert » 31 Mar 2021, 16:03

Yes. paint bucket is 'material'.
Robert
Old Oak
 
Posts: 2006
Joined: 21 Jul 2014, 19:31
Location: Woodford Green
Name: Robert

Re: Stopping 'faces' appearing

Postby RogerS » 31 Mar 2021, 16:36

Robert wrote:Yes. paint bucket is 'material'.


OK..thought so..just checking I wasn't missing a trick !

Do you happen to know if the SU menus are configurable ? I'd like to get Protractor on the 'top' line, as it were.
Fewer Smart things. More smart people.
User avatar
RogerS
Sequoia
 
Posts: 8812
Joined: 21 Jul 2014, 21:07
Location: Nearly finished. OK OK...call me Pinocchio.
Name:

Re: Stopping 'faces' appearing

Postby Robert » 31 Mar 2021, 16:48

Seems you can as i just did it.

Not sure if all this is necessary but..

Right click the menu and choose toolbars....then i selected 'large tool set' which is the one i use....Whist it is selected click on the protractor and a black border appears around it... now it can be dragged to where you want it.

guess you'd have to select whatever tool set you are using if not the same as me.
Robert
Old Oak
 
Posts: 2006
Joined: 21 Jul 2014, 19:31
Location: Woodford Green
Name: Robert

Re: Stopping 'faces' appearing

Postby RogerS » 31 Mar 2021, 17:15

Thanks, Robert. Worked a treat.
Fewer Smart things. More smart people.
User avatar
RogerS
Sequoia
 
Posts: 8812
Joined: 21 Jul 2014, 21:07
Location: Nearly finished. OK OK...call me Pinocchio.
Name:


Return to SketchUp & other 'CAD' Tools

Who is online

Users browsing this forum: No registered users and 1 guest

cron